summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Groh <mail@linusgroh.de>2022-05-05 08:47:36 +0200
committerLinus Groh <mail@linusgroh.de>2022-05-05 22:40:57 +0200
commit0c65624a32e0af2961c32a54f4ea8147397c52ab (patch)
tree10000c2afc723e9c4cabe49ed346365a5897cd3e /Userland/Libraries/LibJS/CMakeLists.txt
parent2c68ec90974918a6eb3c2e9a6d3169bd3c840f47 (diff)
downloadserenity-0c65624a32e0af2961c32a54f4ea8147397c52ab.zip
LibJS: Add AsyncGenerator / AsyncGeneratorPrototype
Not implementing any prototype functions yet, but stubbing out async generator infrastructure will allow us to make some progress in that direction.
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index b96734afba..1d540be54e 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -49,8 +49,10 @@ set(SOURCES
Runtime/AsyncFunctionConstructor.cpp
Runtime/AsyncFunctionDriverWrapper.cpp
Runtime/AsyncFunctionPrototype.cpp
+ Runtime/AsyncGenerator.cpp
Runtime/AsyncGeneratorFunctionConstructor.cpp
Runtime/AsyncGeneratorFunctionPrototype.cpp
+ Runtime/AsyncGeneratorPrototype.cpp
Runtime/AsyncIteratorPrototype.cpp
Runtime/AtomicsObject.cpp
Runtime/BigInt.cpp