summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-10-24 13:30:49 +0200
committerAndreas Kling <kling@serenityos.org>2021-10-24 17:18:05 +0200
commitda77e2aa4f993557174a09dbaa3a1f639db8ddec (patch)
treeb5c6a8287a949b159114feb22b46a52e3a03ec99 /Userland/Libraries/LibJS/CMakeLists.txt
parentb41954182ae7d7b6c3282f1cb2bdea0de0d073b2 (diff)
downloadserenity-da77e2aa4f993557174a09dbaa3a1f639db8ddec.zip
LibJS: Add Bytecode::Executable::dump()
Let's have a helper for producing a consistent executable dump instead of repeating the logic in multiple places.
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index 2f17d0421f..ecfaeb72ad 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -2,6 +2,7 @@ set(SOURCES
AST.cpp
Bytecode/ASTCodegen.cpp
Bytecode/BasicBlock.cpp
+ Bytecode/Executable.cpp
Bytecode/Generator.cpp
Bytecode/Instruction.cpp
Bytecode/Interpreter.cpp