summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Groh <mail@linusgroh.de>2022-01-11 20:20:16 +0100
committerLinus Groh <mail@linusgroh.de>2022-01-11 22:17:39 +0100
commitd527eb62da311d5c73c6821975c1d7fff36df340 (patch)
tree6c0e0b0f0c89a12d1fc98e68b7292fac9798315f /Userland/Libraries/LibJS/CMakeLists.txt
parent205d63c3f0585ef56591c6e64cacf7ab435c5699 (diff)
downloadserenity-d527eb62da311d5c73c6821975c1d7fff36df340.zip
LibJS: Support non-UTC time zones in Temporal :^)
We can now recognize & normalize all time zones from the IANA time zone database and not just 'UTC', which makes the LibJS Temporal implementation a lot more useful! Thanks to the newly added LibTimeZone, this was incredibly easy to implement :^) This already includes these recent editorial changes in the Temporal spec: https://github.com/tc39/proposal-temporal/commit/27bffe1
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index e59cc737fa..4c104dbda5 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -219,4 +219,4 @@ set(SOURCES
)
serenity_lib(LibJS js)
-target_link_libraries(LibJS LibM LibCore LibCrypto LibRegex LibSyntax LibUnicode)
+target_link_libraries(LibJS LibM LibCore LibCrypto LibRegex LibSyntax LibTimeZone LibUnicode)