summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Flynn <trflynn89@pm.me>2021-11-10 12:34:14 -0500
committerLinus Groh <mail@linusgroh.de>2021-11-12 09:17:08 +0000
commit89523f70cf4bc58098136b3ccb5f8542c316cd29 (patch)
tree7d6d000451cbf3d3bb259304f303be4f6fb0df09 /Userland/Libraries/LibJS/CMakeLists.txt
parent04690062639c47feff664b75476543f252d16d2e (diff)
downloadserenity-89523f70cf4bc58098136b3ccb5f8542c316cd29.zip
LibJS: Begin implementing Intl.NumberFormat.prototype.format
There is quite a lot to be done here so this is just a first pass at number formatting. Decimal and percent formatting are mostly working, but only for standard and compact notation (engineering and scientific notation are not implemented here). Currency formatting is parsed, but there is more work to be done to handle e.g. using symbols instead of currency codes ("$" instead of "USD"), and putting spaces around the currency symbol ("USD 2.00" instead of "USD2.00").
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index e79b43f680..ff1add394b 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -92,6 +92,7 @@ set(SOURCES
Runtime/Intl/LocalePrototype.cpp
Runtime/Intl/NumberFormat.cpp
Runtime/Intl/NumberFormatConstructor.cpp
+ Runtime/Intl/NumberFormatFunction.cpp
Runtime/Intl/NumberFormatPrototype.cpp
Runtime/IteratorOperations.cpp
Runtime/IteratorPrototype.cpp