summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Flynn <trflynn89@pm.me>2022-01-25 10:41:57 -0500
committerLinus Groh <mail@linusgroh.de>2022-01-25 19:02:59 +0000
commit79fdec85de20c35eba3ef34cdea12ab678c31586 (patch)
treea6bfb02ca57ae63e6e260048c22e6685f728e9eb /Userland/Libraries/LibJS/CMakeLists.txt
parent0865f71d37943848316791575ac3a2fc3324c938 (diff)
downloadserenity-79fdec85de20c35eba3ef34cdea12ab678c31586.zip
LibJS: Implement a nearly empty Intl.RelativeTimeFormat object
This adds plumbing for the Intl.RelativeTimeFormat object, constructor, and prototype.
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index 9fe951bab9..d1c7e07993 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -106,6 +106,9 @@ set(SOURCES
Runtime/Intl/NumberFormatConstructor.cpp
Runtime/Intl/NumberFormatFunction.cpp
Runtime/Intl/NumberFormatPrototype.cpp
+ Runtime/Intl/RelativeTimeFormat.cpp
+ Runtime/Intl/RelativeTimeFormatConstructor.cpp
+ Runtime/Intl/RelativeTimeFormatPrototype.cpp
Runtime/IteratorOperations.cpp
Runtime/IteratorPrototype.cpp
Runtime/JSONObject.cpp