summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Groh <mail@linusgroh.de>2021-07-15 23:20:43 +0100
committerLinus Groh <mail@linusgroh.de>2021-07-16 01:07:01 +0100
commit7921d8ba916fc578b12c416bb05fead11827493d (patch)
treed662d6fcc6d2f60638bea6cb8d603586018885e4 /Userland/Libraries/LibJS/CMakeLists.txt
parent71234b3716964775a7daf56bcbf19111f9380c20 (diff)
downloadserenity-7921d8ba916fc578b12c416bb05fead11827493d.zip
LibJS: Start implementing Temporal.Duration
This patch adds the Duration object itself, its constructor and prototype (currently empty), and three required abstract operations.
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index a289b85195..2e743f4ded 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -125,6 +125,9 @@ set(SOURCES
Runtime/Temporal/Calendar.cpp
Runtime/Temporal/CalendarConstructor.cpp
Runtime/Temporal/CalendarPrototype.cpp
+ Runtime/Temporal/Duration.cpp
+ Runtime/Temporal/DurationConstructor.cpp
+ Runtime/Temporal/DurationPrototype.cpp
Runtime/Temporal/Instant.cpp
Runtime/Temporal/InstantConstructor.cpp
Runtime/Temporal/InstantPrototype.cpp