summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authordavidot <davidot@serenityos.org>2022-01-27 14:51:21 +0100
committerLinus Groh <mail@linusgroh.de>2022-01-30 17:40:20 +0000
commit6b5c882af344b4ae8b17b4c820a1c2d01d2e0b81 (patch)
tree38e5a67009099b23fecc7d288925718f88cd9b29 /Userland/Libraries/LibJS/CMakeLists.txt
parent202de6ed2587d9c7d5f5288c3df88eee3067d3fb (diff)
downloadserenity-6b5c882af344b4ae8b17b4c820a1c2d01d2e0b81.zip
LibJS: Add support for JSON modules
We now have one supported assertion: 'type' if that is 'json' we attempt to parse the module as JSON.
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index befb3c7d8b..3fb7ad49d4 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -227,6 +227,7 @@ set(SOURCES
Script.cpp
SourceTextModule.cpp
SyntaxHighlighter.cpp
+ SyntheticModule.cpp
Token.cpp
)