summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Groh <mail@linusgroh.de>2021-10-13 21:08:48 +0100
committerLinus Groh <mail@linusgroh.de>2021-10-14 00:41:41 +0100
commit50f87557926962d2c180f0f330b1202ab76a7dd5 (patch)
tree1641e3532c22ef819547b5336226406eb9bc8765 /Userland/Libraries/LibJS/CMakeLists.txt
parentd92967406a43777dabb9aeccd10e58f0b0711e02 (diff)
downloadserenity-50f87557926962d2c180f0f330b1202ab76a7dd5.zip
LibJS: Implement Wrapped Function Exotic Objects
This is a new concept from the ShadowRealm API stage 3 proposal: https://tc39.es/proposal-shadowrealm/#sec-wrapped-function-exotic-objects
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index 90eaadd0c9..57e2a2d626 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -130,6 +130,7 @@ set(SOURCES
Runtime/SetIterator.cpp
Runtime/SetIteratorPrototype.cpp
Runtime/SetPrototype.cpp
+ Runtime/ShadowRealm.cpp
Runtime/Shape.cpp
Runtime/StringConstructor.cpp
Runtime/StringIterator.cpp
@@ -189,6 +190,7 @@ set(SOURCES
Runtime/WeakSet.cpp
Runtime/WeakSetConstructor.cpp
Runtime/WeakSetPrototype.cpp
+ Runtime/WrappedFunction.cpp
Script.cpp
SourceTextModule.cpp
SyntaxHighlighter.cpp