summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Flynn <trflynn89@pm.me>2021-09-06 22:18:48 -0400
committerLinus Groh <mail@linusgroh.de>2022-01-29 20:27:24 +0000
commit4a3e142d554bcf93a720c70e9f817cc79700926f (patch)
treefdc4cfd5dd08b6dca3bd1c4fba280e71314d0799 /Userland/Libraries/LibJS/CMakeLists.txt
parent4d43aeae30f96a034be0e8a5f8a520b26355d674 (diff)
downloadserenity-4a3e142d554bcf93a720c70e9f817cc79700926f.zip
LibJS: Implement a nearly empty Intl.Collator object
This adds plumbing for the Intl.Collator object, constructor, and prototype.
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index a7bf6d0ba8..befb3c7d8b 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -88,6 +88,9 @@ set(SOURCES
Runtime/GlobalObject.cpp
Runtime/IndexedProperties.cpp
Runtime/Intl/AbstractOperations.cpp
+ Runtime/Intl/Collator.cpp
+ Runtime/Intl/CollatorConstructor.cpp
+ Runtime/Intl/CollatorPrototype.cpp
Runtime/Intl/DateTimeFormat.cpp
Runtime/Intl/DateTimeFormatConstructor.cpp
Runtime/Intl/DateTimeFormatFunction.cpp