summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorIdan Horowitz <idan.horowitz@gmail.com>2021-06-09 00:17:17 +0300
committerLinus Groh <mail@linusgroh.de>2021-06-09 11:48:04 +0100
commit2a3090d29290222bcd04203111cf3d63afce5451 (patch)
tree0f2f6ae52979c70c8ccb37e17ccbe29aa930b9c7 /Userland/Libraries/LibJS/CMakeLists.txt
parent0b0f1eda059615bd8d16daa9261239463a1554ec (diff)
downloadserenity-2a3090d29290222bcd04203111cf3d63afce5451.zip
LibJS: Add the SetIterator built-in and Set.prototype.{values, entries}
While this implementation should be complete it is based on HashTable's iterator, which currently follows bucket-order instead of the required insertion order. This can be simply fixed by replacing the underlying HashTable member in Set with an enhanced one that maintains a linked list in insertion order.
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index 5dc140c1c4..1b81a75e9a 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -78,6 +78,8 @@ set(SOURCES
Runtime/ScriptFunction.cpp
Runtime/Set.cpp
Runtime/SetConstructor.cpp
+ Runtime/SetIterator.cpp
+ Runtime/SetIteratorPrototype.cpp
Runtime/SetPrototype.cpp
Runtime/Shape.cpp
Runtime/StringConstructor.cpp