summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibGfx/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Groh <mail@linusgroh.de>2021-12-21 01:17:13 +0100
committerLinus Groh <mail@linusgroh.de>2021-12-21 13:27:27 +0100
commit0356ee95bc16f6bd6de636d27e59a25cd9ce2e82 (patch)
tree768cac5edc5a74f1bb65318deb447c3dee7a4513 /Userland/Libraries/LibGfx/CMakeLists.txt
parent102e0af867358969c28899ccd3c70998d4ead77f (diff)
downloadserenity-0356ee95bc16f6bd6de636d27e59a25cd9ce2e82.zip
LibGfx: Add support for "The Quite OK Image Format" (QOI)
The spec had its first stable release today, so I figured we should support it as well! As usual, by using the regular LibGfx image decoder plugin architecture, we immediately get support for it everywhere: ImageViewer, FileManager thumbnails, PixelPaint, and (with a small change in the subsequent commit) even the Browser :^)
Diffstat (limited to 'Userland/Libraries/LibGfx/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibGfx/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibGfx/CMakeLists.txt b/Userland/Libraries/LibGfx/CMakeLists.txt
index 5e3c86aeee..d048a52df8 100644
--- a/Userland/Libraries/LibGfx/CMakeLists.txt
+++ b/Userland/Libraries/LibGfx/CMakeLists.txt
@@ -28,6 +28,7 @@ set(SOURCES
PNGWriter.cpp
PPMLoader.cpp
Point.cpp
+ QOILoader.cpp
Rect.cpp
ShareableBitmap.cpp
Size.cpp