summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibGPU/CMakeLists.txt
diff options
context:
space:
mode:
authorStephan Unverwerth <s.unverwerth@serenityos.org>2022-12-19 14:25:17 +0100
committerAndreas Kling <kling@serenityos.org>2022-12-26 09:39:20 +0100
commit3b2ded1d4405fc51acb8bbbd24e06cf00198dac8 (patch)
tree35ac8663e9db5c60515f3d5417180b28dd575563 /Userland/Libraries/LibGPU/CMakeLists.txt
parentdc8be499e6e55404a329fac93c663a00961e81bf (diff)
downloadserenity-3b2ded1d4405fc51acb8bbbd24e06cf00198dac8.zip
LibGPU+LibSoftGPU: Move size and pixel format information to GPU::Image
Size and format information are the same for every implementation and do not need to be virtual. This removes the need to reimplement them for each driver.
Diffstat (limited to 'Userland/Libraries/LibGPU/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibGPU/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibGPU/CMakeLists.txt b/Userland/Libraries/LibGPU/CMakeLists.txt
index 030c5b2f86..cf4fdbd1f1 100644
--- a/Userland/Libraries/LibGPU/CMakeLists.txt
+++ b/Userland/Libraries/LibGPU/CMakeLists.txt
@@ -1,5 +1,6 @@
set(SOURCES
Driver.cpp
+ Image.cpp
)
serenity_lib(LibGPU gpu)