summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibGL/CMakeLists.txt
diff options
context:
space:
mode:
authorJelle Raaijmakers <jelle@gmta.nl>2022-03-08 12:16:56 +0100
committerAndreas Kling <kling@serenityos.org>2022-03-08 15:32:35 +0100
commitc21a3b3029587961d39d2da95c7c43074e7e6076 (patch)
tree5801b5fdb0aff1f2203fc579fc99e321531f7f24 /Userland/Libraries/LibGL/CMakeLists.txt
parentc87d3521e4e3099fe7b51b25f70ff52ea6807fcb (diff)
downloadserenity-c21a3b3029587961d39d2da95c7c43074e7e6076.zip
LibGL: Better handling of texture targets and default textures
We were lacking support for default textures (i.e. calling `glBindTexture` with a `texture` argument of `0`) which caused our Quake2 port to render red screens whenever a video was playing. Every texture unit is now initialized with a default 2D texture. Additionally, we had this concept of a "currently bound target" on our texture units which is not how OpenGL wants us to handle targets. Calling `glBindTexture` should set the texture for the provided target only, making it sort of an alias for future operations on the same target. Finally, `glDeleteTextures` should not remove the bound texture from the target in the texture unit, but it should reset it to the default texture.
Diffstat (limited to 'Userland/Libraries/LibGL/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibGL/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Userland/Libraries/LibGL/CMakeLists.txt b/Userland/Libraries/LibGL/CMakeLists.txt
index 29b7b61e44..c56c7dd405 100644
--- a/Userland/Libraries/LibGL/CMakeLists.txt
+++ b/Userland/Libraries/LibGL/CMakeLists.txt
@@ -16,7 +16,6 @@ set(SOURCES
SoftwareGLContext.cpp
Tex/NameAllocator.cpp
Tex/Texture2D.cpp
- Tex/TextureUnit.cpp
)
serenity_lib(LibGL gl)