summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibEDID/CMakeLists.txt
diff options
context:
space:
mode:
authorTom <tomut@yahoo.com>2022-01-17 16:53:17 -0700
committerLinus Groh <mail@linusgroh.de>2022-01-23 22:45:21 +0000
commit869c20b05dba6230d96166f2a5b74e823653274a (patch)
treec2b4404f0f14591c229ca77439893eaeea601961 /Userland/Libraries/LibEDID/CMakeLists.txt
parentab1075e2961107a9f9d411d4afc0f4fe144dec36 (diff)
downloadserenity-869c20b05dba6230d96166f2a5b74e823653274a.zip
Meta+LibEDID: Download and generate the PNP ID database
This downloads the UEFI's published PNP ID database and generates a lookup table for use in LibEDID. The lookup table isn't optimized at all, but this can be easily done at a later point if needed.
Diffstat (limited to 'Userland/Libraries/LibEDID/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibEDID/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Userland/Libraries/LibEDID/CMakeLists.txt b/Userland/Libraries/LibEDID/CMakeLists.txt
index a3f981385f..e50d8022d1 100644
--- a/Userland/Libraries/LibEDID/CMakeLists.txt
+++ b/Userland/Libraries/LibEDID/CMakeLists.txt
@@ -1,8 +1,12 @@
+include(${SerenityOS_SOURCE_DIR}/Meta/CMake/pnp_ids.cmake)
+
set(SOURCES
DMT.cpp
EDID.cpp
VIC.cpp
+ ${PNP_IDS_SOURCES}
)
serenity_lib(LibEDID edid)
target_link_libraries(LibEDID LibC)
+target_compile_definitions(LibEDID PRIVATE ENABLE_PNP_IDS_DATA=$<BOOL:${ENABLE_PNP_IDS_DOWNLOAD}>)