summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibDeviceTree/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaster <akaster@serenityos.org>2021-10-17 19:09:18 -0600
committerBrian Gianforcaro <b.gianfo@gmail.com>2021-10-21 19:20:03 -0700
commit644928314a4f33ed37d9998f44f9b4a2776aaec8 (patch)
tree3c8c36c2590a47e729250b86d0ebe922efda1a7f /Userland/Libraries/LibDeviceTree/CMakeLists.txt
parent4ffee78146c2d685b189eb256efc585e92fbac2c (diff)
downloadserenity-644928314a4f33ed37d9998f44f9b4a2776aaec8.zip
Libraries: Add LibDeviceTree for manipulating OpenFirmware Device Trees
Starting with header validation and a dump() method that can be used to debug future parsing work.
Diffstat (limited to 'Userland/Libraries/LibDeviceTree/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibDeviceTree/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Userland/Libraries/LibDeviceTree/CMakeLists.txt b/Userland/Libraries/LibDeviceTree/CMakeLists.txt
new file mode 100644
index 0000000000..f81192fc3c
--- /dev/null
+++ b/Userland/Libraries/LibDeviceTree/CMakeLists.txt
@@ -0,0 +1,7 @@
+
+set(SOURCES
+ Validation.cpp
+)
+
+serenity_lib(LibDeviceTree DeviceTree)
+target_link_libraries(LibDeviceTree LibC LibCore)