summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibAudio/CMakeLists.txt
diff options
context:
space:
mode:
authorkleines Filmröllchen <filmroellchen@serenityos.org>2023-03-18 14:12:25 +0100
committerLinus Groh <mail@linusgroh.de>2023-03-19 00:28:02 +0000
commit0cd0565abc5a0abf8df41268b890d59dc5a92f06 (patch)
treea8b65866b1c1d86ae93acf5629e84d7b431bdd09 /Userland/Libraries/LibAudio/CMakeLists.txt
parentc66f7f2e7cb75de6a1bc0d62d688b6a58ac6b670 (diff)
downloadserenity-0cd0565abc5a0abf8df41268b890d59dc5a92f06.zip
LibAudio: Improve FLAC seeking
"Improve" is an understatement, since this commit makes all FLAC files seek without errors, mostly with high accuracy, and partially even fast: - A new generic seek table type is introduced, which keeps an always-sorted list of seek points, which allows it to use binary search and fast insertion. - Automatic seek points are inserted according to two heuristics (distance between seek points and minimum seek precision), which not only builds a seek table for already-played sections of the file, but improves seek precision even for files with an existing seek table. - Manual seeking by skipping frames works properly now and is still used as a last resort.
Diffstat (limited to 'Userland/Libraries/LibAudio/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibAudio/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibAudio/CMakeLists.txt b/Userland/Libraries/LibAudio/CMakeLists.txt
index 8f9f665acb..cf807e8ed1 100644
--- a/Userland/Libraries/LibAudio/CMakeLists.txt
+++ b/Userland/Libraries/LibAudio/CMakeLists.txt
@@ -1,4 +1,5 @@
set(SOURCES
+ GenericTypes.cpp
SampleFormats.cpp
Loader.cpp
WavLoader.cpp