summaryrefslogtreecommitdiff
path: root/Userland/Libraries/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaster <akaster@serenityos.org>2021-07-26 00:08:22 -0600
committerLinus Groh <mail@linusgroh.de>2021-07-29 21:46:25 +0100
commitaf9be6e093c571aa9afbbfc6276572bba0aa2ff4 (patch)
tree2ef679858ad2015d3c16a836c12913583be10a6a /Userland/Libraries/CMakeLists.txt
parent08ddfb30d76844efafc82f5727991b78cd16cc6b (diff)
downloadserenity-af9be6e093c571aa9afbbfc6276572bba0aa2ff4.zip
LibTTF/LibGfx: Remove circular dependency by merging LibTTF into LibGfx
LibTTF has a concrete dependency on LibGfx for things like Gfx::Bitmap, and LibGfx has a concrete dependency in the TTF::Font class in Gfx::FontDatabase. This circular dependency works fine for Serenity and Lagom Linux builds of the two libraries. It also works fine for static library builds on Lagom macOS builds. However, future changes will make Lagom use shared libraries, and circular library dependencies are not tolerated in macOS.
Diffstat (limited to 'Userland/Libraries/CMakeLists.txt')
-rw-r--r--Userland/Libraries/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Userland/Libraries/CMakeLists.txt b/Userland/Libraries/CMakeLists.txt
index 56cdc75ed3..c4ebb79bb0 100644
--- a/Userland/Libraries/CMakeLists.txt
+++ b/Userland/Libraries/CMakeLists.txt
@@ -42,7 +42,6 @@ add_subdirectory(LibTest)
add_subdirectory(LibTextCodec)
add_subdirectory(LibThreading)
add_subdirectory(LibTLS)
-add_subdirectory(LibTTF)
add_subdirectory(LibUnicode)
add_subdirectory(LibUSBDB)
add_subdirectory(LibVideo)