summaryrefslogtreecommitdiff
path: root/Userland/Libraries/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Olsson <matthewcolsson@gmail.com>2021-04-30 18:23:17 -0700
committerAndreas Kling <kling@serenityos.org>2021-05-10 10:32:39 +0200
commita8f5b6aaa3405e4b4eda49888ee9da8572d5473d (patch)
treee5c95bb185071cda2f81d5802cd67b366533eb2f /Userland/Libraries/CMakeLists.txt
parentaf9a7b13748cc4ccffe6f257c520b2a3b040102b (diff)
downloadserenity-a8f5b6aaa3405e4b4eda49888ee9da8572d5473d.zip
LibPDF: Create basic object structure
This commit is the start of LibPDF, and introduces some basic structure objects. This emulates LibJS's Value structure, where Value is a simple class that can contain a pointer to a more complex Object class with more data. All of the basic PDF objects have a representation.
Diffstat (limited to 'Userland/Libraries/CMakeLists.txt')
-rw-r--r--Userland/Libraries/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/CMakeLists.txt b/Userland/Libraries/CMakeLists.txt
index ae9734ef40..548498ba85 100644
--- a/Userland/Libraries/CMakeLists.txt
+++ b/Userland/Libraries/CMakeLists.txt
@@ -26,6 +26,7 @@ add_subdirectory(LibLine)
add_subdirectory(LibM)
add_subdirectory(LibMarkdown)
add_subdirectory(LibPCIDB)
+add_subdirectory(LibPDF)
add_subdirectory(LibProtocol)
add_subdirectory(LibPthread)
add_subdirectory(LibRegex)