summaryrefslogtreecommitdiff
path: root/Userland/Libraries/CMakeLists.txt
diff options
context:
space:
mode:
authorFalseHonesty <thefalsehonesty@gmail.com>2021-06-05 16:06:55 -0400
committerAndreas Kling <kling@serenityos.org>2021-06-06 17:47:00 +0200
commit403bb07443f482734597f0e1c59706d79d7d1ac4 (patch)
tree3860327eddeecc8e0dad08eb409b44b392d7aaaa /Userland/Libraries/CMakeLists.txt
parent6a15bd06cb5621f41e7650926ecd86bbbb912873 (diff)
downloadserenity-403bb07443f482734597f0e1c59706d79d7d1ac4.zip
LibVideo: Scaffold LibVideo and implement simplistic Matroska parser
This commit initializes the LibVideo library and implements parsing basic Matroska container files. Currently, it will only parse audio and video tracks.
Diffstat (limited to 'Userland/Libraries/CMakeLists.txt')
-rw-r--r--Userland/Libraries/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/CMakeLists.txt b/Userland/Libraries/CMakeLists.txt
index d4c55908b7..5a7543656a 100644
--- a/Userland/Libraries/CMakeLists.txt
+++ b/Userland/Libraries/CMakeLists.txt
@@ -41,6 +41,7 @@ add_subdirectory(LibTextCodec)
add_subdirectory(LibThreading)
add_subdirectory(LibTLS)
add_subdirectory(LibTTF)
+add_subdirectory(LibVideo)
add_subdirectory(LibVT)
add_subdirectory(LibWasm)
add_subdirectory(LibWeb)