summaryrefslogtreecommitdiff
path: root/Userland/Games/Minesweeper/CMakeLists.txt
diff options
context:
space:
mode:
authorPedro Pereira <pmh.pereira@gmail.com>2021-11-02 21:35:58 +0000
committerLinus Groh <mail@linusgroh.de>2021-11-14 23:52:55 +0000
commit557075465ccf32337c10089a344687ae34e1aff6 (patch)
tree9fff3745a10d32b297b90e223ec556a32d88ebe2 /Userland/Games/Minesweeper/CMakeLists.txt
parent42071f69cf339d40439b8ca9fc7439669614a31c (diff)
downloadserenity-557075465ccf32337c10089a344687ae34e1aff6.zip
Minesweeper: Add "Custom game..." difficulty
This adds a dialog window which allows us to customize the size of the board and the amount of mines that will be placed. The current max amount of mines is 50% of the total number of cells due to the fact that the generator algorithm takes too long to create a board for higher percentages of mines.
Diffstat (limited to 'Userland/Games/Minesweeper/CMakeLists.txt')
-rw-r--r--Userland/Games/Minesweeper/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Userland/Games/Minesweeper/CMakeLists.txt b/Userland/Games/Minesweeper/CMakeLists.txt
index 8d08e56e17..fc74b7124b 100644
--- a/Userland/Games/Minesweeper/CMakeLists.txt
+++ b/Userland/Games/Minesweeper/CMakeLists.txt
@@ -4,7 +4,11 @@ serenity_component(
TARGETS Minesweeper
)
+compile_gml(MinesweeperCustomGameWindow.gml MinesweeperCustomGameWindowGML.h minesweeper_custom_game_window_gml)
+
set(SOURCES
+ MinesweeperCustomGameWindowGML.h
+ CustomGameDialog.cpp
Field.cpp
main.cpp
)