summaryrefslogtreecommitdiff
path: root/Userland/DevTools/Profiler/CMakeLists.txt
diff options
context:
space:
mode:
authorGunnar Beutner <gbeutner@serenityos.org>2021-07-22 18:41:52 +0200
committerAndreas Kling <kling@serenityos.org>2021-07-22 21:38:23 +0200
commit60d6137e7345f05cc94462ac1d873a28d5c672fc (patch)
treec9df537235346a74152a74841d437f7b9b9fcf1a /Userland/DevTools/Profiler/CMakeLists.txt
parent6115258a5c6fc12c7d8276938a14a2b6b2339fb4 (diff)
downloadserenity-60d6137e7345f05cc94462ac1d873a28d5c672fc.zip
Userland: Use /proc/kernel_base to determine the kernel base address
This removes all the hard-coded kernel base addresses from userspace tools. One downside for this is that e.g. Profiler no longer uses a different color for kernel symbols when run as a non-root user.
Diffstat (limited to 'Userland/DevTools/Profiler/CMakeLists.txt')
-rw-r--r--Userland/DevTools/Profiler/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Userland/DevTools/Profiler/CMakeLists.txt b/Userland/DevTools/Profiler/CMakeLists.txt
index 3b17cc360d..f08eebaa15 100644
--- a/Userland/DevTools/Profiler/CMakeLists.txt
+++ b/Userland/DevTools/Profiler/CMakeLists.txt
@@ -19,4 +19,4 @@ set(SOURCES
)
serenity_app(Profiler ICON app-profiler)
-target_link_libraries(Profiler LibGUI LibDesktop LibX86)
+target_link_libraries(Profiler LibGUI LibDesktop LibX86 LibSymbolication)