summaryrefslogtreecommitdiff
path: root/Userland/DevTools/HackStudio/CMakeLists.txt
diff options
context:
space:
mode:
authorKarol Kosek <krkk@krkk.ct8.pl>2021-07-29 21:06:52 +0200
committerGunnar Beutner <gunnar@beutner.name>2021-07-31 08:18:01 +0200
commitbf322e072f40d409eea336ea74cfa42df7da04e3 (patch)
treea921990ada1d8a3db992e010968c8bb8f52abbb3 /Userland/DevTools/HackStudio/CMakeLists.txt
parent68088b629bed6883f2e9f5e389118030d319860b (diff)
downloadserenity-bf322e072f40d409eea336ea74cfa42df7da04e3.zip
HackStudio: Add syntax highlighting for HTML, Shell, and SQL files
.html files were recognised before -- the name was shown on the statusbar, but it didn't actually enable the syntax highlighting. This also sneaks a highlighting for JSON using JS highlighting. It isn't technically correct, but so does TextEditor. :^)
Diffstat (limited to 'Userland/DevTools/HackStudio/CMakeLists.txt')
-rw-r--r--Userland/DevTools/HackStudio/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Userland/DevTools/HackStudio/CMakeLists.txt b/Userland/DevTools/HackStudio/CMakeLists.txt
index 61e0274007..56b4fa7313 100644
--- a/Userland/DevTools/HackStudio/CMakeLists.txt
+++ b/Userland/DevTools/HackStudio/CMakeLists.txt
@@ -50,5 +50,5 @@ set(SOURCES
)
serenity_app(HackStudio ICON app-hack-studio)
-target_link_libraries(HackStudio LibWeb LibMarkdown LibGUI LibCpp LibGfx LibCore LibVT LibDebug LibX86 LibDiff LibShell LibSymbolication LibRegex)
+target_link_libraries(HackStudio LibWeb LibMarkdown LibGUI LibCpp LibGfx LibCore LibVT LibDebug LibX86 LibDiff LibShell LibSymbolication LibRegex LibSQL)
add_dependencies(HackStudio CppLanguageServer)