summaryrefslogtreecommitdiff
path: root/Userland/DevTools/HackStudio/CMakeLists.txt
diff options
context:
space:
mode:
authorItamar <itamar8910@gmail.com>2022-01-07 17:20:28 +0200
committerAndreas Kling <kling@serenityos.org>2022-01-12 14:55:19 +0100
commitbb6324a9a910ddd81e7a831a117d32a7a68a9557 (patch)
tree15691eb7f23ef03dbfa37a08a0e0aa2e9cabffdc /Userland/DevTools/HackStudio/CMakeLists.txt
parentf464ae84ce5b1acd355a43b37156fcab476ac3e7 (diff)
downloadserenity-bb6324a9a910ddd81e7a831a117d32a7a68a9557.zip
HackStudio: Add ProjectBuilder component
ProjectBuilder takes care of building and running the current project from Hack Studio. The existing functionality of building javascript and Makefile projects remains, and in addition to it the ability to build standalone serenity components is added. If the Hack Studio project is the serenity repository itself, ProjectBuilder will attempt building the component that the currently active file belongs to. It does so by creating a new CMake file which adds the component as a build subdirectory. It also parses all CMake files in the serenity repository to gather all available libraries. It declares the libraries and their dependencies in this CMake file. It then uses the HACKSTUDIO_BUILD CMake option to direct the build system to use this CMake file instead of doing a full system build.
Diffstat (limited to 'Userland/DevTools/HackStudio/CMakeLists.txt')
-rw-r--r--Userland/DevTools/HackStudio/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/DevTools/HackStudio/CMakeLists.txt b/Userland/DevTools/HackStudio/CMakeLists.txt
index 7dc1b35db6..f86e4e02e5 100644
--- a/Userland/DevTools/HackStudio/CMakeLists.txt
+++ b/Userland/DevTools/HackStudio/CMakeLists.txt
@@ -43,6 +43,7 @@ set(SOURCES
LanguageClient.cpp
Locator.cpp
Project.cpp
+ ProjectBuilder.cpp
ProjectDeclarations.cpp
ProjectFile.cpp
ProjectTemplate.cpp