summaryrefslogtreecommitdiff
path: root/Userland/DevTools/HackStudio/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Vella <nick@nxk.io>2021-02-13 21:22:48 +1100
committerAndreas Kling <kling@serenityos.org>2021-02-13 19:49:30 +0100
commitb6715772234e3e55235b21fff05487e29727bfe8 (patch)
tree39a93db4d872f1de1c04985b11f78009fc02d3cd /Userland/DevTools/HackStudio/CMakeLists.txt
parenta6fdc17f3f0add00fd15a1223415e8dd04ceb6f8 (diff)
downloadserenity-b6715772234e3e55235b21fff05487e29727bfe8.zip
HackStudio: Project templates and New Project dialog
This commit adds a simple project template system to HackStudio, as well as a pretty New Project dialog, inspired by early VS.NET and MS Office.
Diffstat (limited to 'Userland/DevTools/HackStudio/CMakeLists.txt')
-rw-r--r--Userland/DevTools/HackStudio/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/Userland/DevTools/HackStudio/CMakeLists.txt b/Userland/DevTools/HackStudio/CMakeLists.txt
index e31a214a62..7f4a87858b 100644
--- a/Userland/DevTools/HackStudio/CMakeLists.txt
+++ b/Userland/DevTools/HackStudio/CMakeLists.txt
@@ -1,6 +1,8 @@
add_subdirectory(LanguageServers)
add_subdirectory(LanguageClients)
+compile_gml(Dialogs/NewProjectDialog.gml Dialogs/NewProjectDialogGML.h new_project_dialog_gml)
+
set(SOURCES
CodeDocument.cpp
CursorTool.cpp
@@ -11,6 +13,9 @@ set(SOURCES
Debugger/DisassemblyWidget.cpp
Debugger/RegistersModel.cpp
Debugger/VariablesModel.cpp
+ Dialogs/NewProjectDialog.cpp
+ Dialogs/NewProjectDialogGML.h
+ Dialogs/ProjectTemplatesModel.cpp
Editor.cpp
EditorWrapper.cpp
FindInFilesWidget.cpp
@@ -26,6 +31,7 @@ set(SOURCES
Locator.cpp
Project.cpp
ProjectFile.cpp
+ ProjectTemplate.cpp
TerminalWrapper.cpp
WidgetTool.cpp
WidgetTreeModel.cpp
@@ -33,5 +39,5 @@ set(SOURCES
)
serenity_app(HackStudio ICON app-hack-studio)
-target_link_libraries(HackStudio LibWeb LibMarkdown LibGUI LibCpp LibGfx LibCore LibVT LibDebug LibX86 LibDiff LibShell)
+target_link_libraries(HackStudio LibWeb LibMarkdown LibGUI LibCpp LibGfx LibCore LibVT LibDebug LibX86 LibDiff LibShell LibRegex)
add_dependencies(HackStudio CppLanguageServer)