summaryrefslogtreecommitdiff
path: root/Userland/DevTools/HackStudio/CMakeLists.txt
diff options
context:
space:
mode:
authorGunnar Beutner <gbeutner@serenityos.org>2021-06-15 15:16:32 +0200
committerAndreas Kling <kling@serenityos.org>2021-06-17 11:03:51 +0200
commit631d36fd9821e48b3b3b53ac609e2e50b254d15b (patch)
tree48f8af868a0ff3a66bb8d8435aca497bef093113 /Userland/DevTools/HackStudio/CMakeLists.txt
parent6e094b8dbe91bea983284c747eaba5c6083eb364 (diff)
downloadserenity-631d36fd9821e48b3b3b53ac609e2e50b254d15b.zip
Everywhere: Add component declarations
This adds component declarations so that users can select to not build certain parts of the OS.
Diffstat (limited to 'Userland/DevTools/HackStudio/CMakeLists.txt')
-rw-r--r--Userland/DevTools/HackStudio/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Userland/DevTools/HackStudio/CMakeLists.txt b/Userland/DevTools/HackStudio/CMakeLists.txt
index 6b623e2281..06bd5b3c57 100644
--- a/Userland/DevTools/HackStudio/CMakeLists.txt
+++ b/Userland/DevTools/HackStudio/CMakeLists.txt
@@ -1,3 +1,10 @@
+serenity_component(
+ HackStudio
+ RECOMMENDED
+ TARGETS HackStudio
+ DEPENDS CppLanguageServer ShellLanguageServer
+)
+
add_subdirectory(LanguageServers)
add_subdirectory(LanguageClients)