summaryrefslogtreecommitdiff
path: root/Userland/DevTools/HackStudio/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Flynn <trflynn89@pm.me>2021-12-29 13:10:12 -0500
committerAndreas Kling <kling@serenityos.org>2021-12-30 14:18:12 +0100
commit565a880ce5a14bac817c73916e91ebfa04c8b99b (patch)
treec72ea83b52dd43711c4f0fc32367165d839e77ba /Userland/DevTools/HackStudio/CMakeLists.txt
parent0c84957eba4ef71ac45d7b1dcf6a79146448ebd5 (diff)
downloadserenity-565a880ce5a14bac817c73916e91ebfa04c8b99b.zip
Userland: Link directly against LibUnicodeData where needed
This is partially a revert of commits: 10a8b6d4116c6a627a6c189154af032f69b29c21 561b67a1add82538502ef2f5733f1d86718898ad Rather than adding the prot_exec pledge requried to use dlopen(), we can link directly against LibUnicodeData in applications that we know need that library. This might make the dlopen() dance a bit unnecessary. The same purpose might now be fulfilled with weak symbols. That can be revisted next, but for now, this at least removes the potential security risk of apps like the Browser having prot_exec privileges.
Diffstat (limited to 'Userland/DevTools/HackStudio/CMakeLists.txt')
-rw-r--r--Userland/DevTools/HackStudio/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/DevTools/HackStudio/CMakeLists.txt b/Userland/DevTools/HackStudio/CMakeLists.txt
index 8f6cc83d5e..e9a2a29a66 100644
--- a/Userland/DevTools/HackStudio/CMakeLists.txt
+++ b/Userland/DevTools/HackStudio/CMakeLists.txt
@@ -51,4 +51,5 @@ set(SOURCES
serenity_app(HackStudio ICON app-hack-studio)
target_link_libraries(HackStudio LibWeb LibMarkdown LibGUI LibCpp LibGfx LibCore LibVT LibDebug LibX86 LibDiff LibShell LibSymbolication LibRegex LibSQL LibCoredump LibMain)
+link_with_unicode_data(HackStudio)
add_dependencies(HackStudio CppLanguageServer)