summaryrefslogtreecommitdiff
path: root/Userland/DevTools/HackStudio/CMakeLists.txt
diff options
context:
space:
mode:
authorFalseHonesty <thefalsehonesty@gmail.com>2021-04-12 21:02:47 -0400
committerLinus Groh <mail@linusgroh.de>2021-04-25 19:03:57 +0200
commit60d329a18624ffc1ce84498ce1378f078cc8baaa (patch)
tree85c7751298caec2c6f536a4160b2c4ba70d5e73a /Userland/DevTools/HackStudio/CMakeLists.txt
parentbee16bb83ac935fe80a8aa9bf4a381b091952045 (diff)
downloadserenity-60d329a18624ffc1ce84498ce1378f078cc8baaa.zip
HackStudio: Add evaluate expression popup to debugger
This implements a dialog that can be used to evaluate a JS expression in the HackStudio's Debugger context. It also implements simple C++ Variable <-> JS Value conversion, allowing for JS expressions to read/write variables in the debugger scope. Currently, C++ structs are mapped to JS objects by way of a JS proxy, however this leads to issues when printing, so this will be changed in a later commit.
Diffstat (limited to 'Userland/DevTools/HackStudio/CMakeLists.txt')
-rw-r--r--Userland/DevTools/HackStudio/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Userland/DevTools/HackStudio/CMakeLists.txt b/Userland/DevTools/HackStudio/CMakeLists.txt
index e2f41f2a10..7342dc1de8 100644
--- a/Userland/DevTools/HackStudio/CMakeLists.txt
+++ b/Userland/DevTools/HackStudio/CMakeLists.txt
@@ -5,13 +5,15 @@ compile_gml(Dialogs/NewProjectDialog.gml Dialogs/NewProjectDialogGML.h new_proje
set(SOURCES
CodeDocument.cpp
- ClassViewWidget.cpp
+ ClassViewWidget.cpp
CursorTool.cpp
Debugger/BacktraceModel.cpp
Debugger/DebugInfoWidget.cpp
Debugger/Debugger.cpp
+ Debugger/DebuggerGlobalJSObject.cpp
Debugger/DisassemblyModel.cpp
Debugger/DisassemblyWidget.cpp
+ Debugger/EvaluateExpressionDialog.cpp
Debugger/RegistersModel.cpp
Debugger/VariablesModel.cpp
Dialogs/NewProjectDialog.cpp