summaryrefslogtreecommitdiff
path: root/Userland/DevTools/CMakeLists.txt
diff options
context:
space:
mode:
authorHendiadyoin1 <leon2002.la@gmail.com>2021-06-30 15:27:32 +0200
committerAndreas Kling <kling@serenityos.org>2021-06-30 19:05:51 +0200
commit59eea93d2aa7a903bfc90a2e4e033ffa521b7b3a (patch)
tree793d1752a33129beeb3c6db9e269a3d68bdde00b /Userland/DevTools/CMakeLists.txt
parent7a3b057a20b453e919ccc7a73e1b4746b6121dcb (diff)
downloadserenity-59eea93d2aa7a903bfc90a2e4e033ffa521b7b3a.zip
Userland: Disable Hackstudio and UE on x86_64
Diffstat (limited to 'Userland/DevTools/CMakeLists.txt')
-rw-r--r--Userland/DevTools/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/Userland/DevTools/CMakeLists.txt b/Userland/DevTools/CMakeLists.txt
index b0d5aee0e3..5c2ed4a8aa 100644
--- a/Userland/DevTools/CMakeLists.txt
+++ b/Userland/DevTools/CMakeLists.txt
@@ -1,5 +1,8 @@
-add_subdirectory(HackStudio)
add_subdirectory(Inspector)
add_subdirectory(Playground)
add_subdirectory(Profiler)
-add_subdirectory(UserspaceEmulator)
+
+if("${SERENITY_ARCH}" STREQUAL "i686")
+ add_subdirectory(HackStudio)
+ add_subdirectory(UserspaceEmulator)
+endif()