summaryrefslogtreecommitdiff
path: root/Userland/Applications/Spreadsheet/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-01-12 12:05:23 +0100
committerAndreas Kling <kling@serenityos.org>2021-01-12 12:05:23 +0100
commitdc28c07fa526841e05e16161c74a6c23984f1dd5 (patch)
treed68796bc7708eba33fbf7247e1a92188ac5acf6f /Userland/Applications/Spreadsheet/CMakeLists.txt
parentaa939c4b4b8a7eb1d22b166ebb5fb737d6e66714 (diff)
downloadserenity-dc28c07fa526841e05e16161c74a6c23984f1dd5.zip
Applications: Move to Userland/Applications/
Diffstat (limited to 'Userland/Applications/Spreadsheet/CMakeLists.txt')
-rw-r--r--Userland/Applications/Spreadsheet/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/Userland/Applications/Spreadsheet/CMakeLists.txt b/Userland/Applications/Spreadsheet/CMakeLists.txt
new file mode 100644
index 0000000000..f41922655a
--- /dev/null
+++ b/Userland/Applications/Spreadsheet/CMakeLists.txt
@@ -0,0 +1,28 @@
+compile_gml(CondFormatting.gml CondFormattingGML.h cond_fmt_gml)
+compile_gml(CondView.gml CondFormattingViewGML.h cond_fmt_view_gml)
+
+set(SOURCES
+ Cell.cpp
+ CellSyntaxHighlighter.cpp
+ CellType/Date.cpp
+ CellType/Format.cpp
+ CellType/Identity.cpp
+ CellType/Numeric.cpp
+ CellType/String.cpp
+ CellType/Type.cpp
+ CellTypeDialog.cpp
+ CondFormattingGML.h
+ CondFormattingViewGML.h
+ HelpWindow.cpp
+ JSIntegration.cpp
+ Readers/XSV.cpp
+ Spreadsheet.cpp
+ SpreadsheetModel.cpp
+ SpreadsheetView.cpp
+ SpreadsheetWidget.cpp
+ Workbook.cpp
+ main.cpp
+)
+
+serenity_app(Spreadsheet ICON app-spreadsheet)
+target_link_libraries(Spreadsheet LibGUI LibJS LibWeb)