summaryrefslogtreecommitdiff
path: root/Userland/Applications/Settings/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-07-25 21:52:39 +0200
committerAndreas Kling <kling@serenityos.org>2021-07-26 00:39:10 +0200
commit87a22a77e9e1dc728358192c68da2320078b40dd (patch)
treed2b16ad64d861b8ec9931a11f767a9eea0126436 /Userland/Applications/Settings/CMakeLists.txt
parent99f57d0a400060168f2d8b211761b45d0dd3e1f5 (diff)
downloadserenity-87a22a77e9e1dc728358192c68da2320078b40dd.zip
Settings: Add a very simple Settings application
This is really just a launcher app that gathers all the installed apps in the "Settings" category and presents them in a single window.
Diffstat (limited to 'Userland/Applications/Settings/CMakeLists.txt')
-rw-r--r--Userland/Applications/Settings/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Userland/Applications/Settings/CMakeLists.txt b/Userland/Applications/Settings/CMakeLists.txt
new file mode 100644
index 0000000000..edbabd23b2
--- /dev/null
+++ b/Userland/Applications/Settings/CMakeLists.txt
@@ -0,0 +1,12 @@
+serenity_component(
+ Settings
+ REQUIRED
+ TARGETS Settings
+)
+
+set(SOURCES
+ main.cpp
+)
+
+serenity_app(Settings ICON app-settings)
+target_link_libraries(Settings LibGUI LibDesktop)