summaryrefslogtreecommitdiff
path: root/Userland/Applications/PixelPaint/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Christiansen <tobi@tobyase.de>2021-08-01 17:19:10 +0200
committerAli Mohammad Pur <Ali.mpfard@gmail.com>2021-08-07 02:52:47 +0430
commit515bbd0b833f8fb9abbcc5e50d3d4318f25c2168 (patch)
treecc296387cef1cb94e4b3ed9e66be1031e10b8da2 /Userland/Applications/PixelPaint/CMakeLists.txt
parenta717caa4b7439cb81a612ed0a85d134d6c3af070 (diff)
downloadserenity-515bbd0b833f8fb9abbcc5e50d3d4318f25c2168.zip
PixelPaint: Add a Dialog for the creation of a Guide
You can select whether you want a horizontal or a vertical Guide and specify the offset you want it to be at.
Diffstat (limited to 'Userland/Applications/PixelPaint/CMakeLists.txt')
-rw-r--r--Userland/Applications/PixelPaint/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Userland/Applications/PixelPaint/CMakeLists.txt b/Userland/Applications/PixelPaint/CMakeLists.txt
index 117dda935b..823ac3c4d1 100644
--- a/Userland/Applications/PixelPaint/CMakeLists.txt
+++ b/Userland/Applications/PixelPaint/CMakeLists.txt
@@ -6,10 +6,13 @@ serenity_component(
)
compile_gml(PixelPaintWindow.gml PixelPaintWindowGML.h pixel_paint_window_gml)
+compile_gml(CreateNewGuideDialog.gml CreateNewGuideDialogGML.h create_new_guide_dialog_gml)
set(SOURCES
BrushTool.cpp
BucketTool.cpp
+ CreateNewGuideDialog.cpp
+ CreateNewGuideDialogGML.h
CreateNewImageDialog.cpp
CreateNewLayerDialog.cpp
EllipseTool.cpp