summaryrefslogtreecommitdiff
path: root/Userland/Applications/PixelPaint/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-06-14 17:36:18 +0200
committerAndreas Kling <kling@serenityos.org>2021-06-14 18:25:17 +0200
commit1b897ec561f4731353a025ec028e1fbab7f335a2 (patch)
treed015885fe1a9465a99c7eab53cc80d71abbdff97 /Userland/Applications/PixelPaint/CMakeLists.txt
parent96b52f13e47a33321c13308c5b2b7690fad2d488 (diff)
downloadserenity-1b897ec561f4731353a025ec028e1fbab7f335a2.zip
PixelPaint: Add a Selection class (ImageEditor has a Selection)
This will represent a complex, region-based selection in the future. For now though, it's just a simple rectangle. :^)
Diffstat (limited to 'Userland/Applications/PixelPaint/CMakeLists.txt')
-rw-r--r--Userland/Applications/PixelPaint/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Applications/PixelPaint/CMakeLists.txt b/Userland/Applications/PixelPaint/CMakeLists.txt
index e937c025f3..d18d3c47bc 100644
--- a/Userland/Applications/PixelPaint/CMakeLists.txt
+++ b/Userland/Applications/PixelPaint/CMakeLists.txt
@@ -21,6 +21,7 @@ set(SOURCES
PixelPaintWindowGML.h
RectangleTool.cpp
RectangleSelectTool.cpp
+ Selection.cpp
SprayTool.cpp
ToolboxWidget.cpp
ToolPropertiesWidget.cpp