summaryrefslogtreecommitdiff
path: root/Userland/Applications/Mail/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke <luke.wilde@live.co.uk>2021-07-22 18:44:59 +0100
committerAli Mohammad Pur <Ali.mpfard@gmail.com>2021-07-24 20:11:28 +0430
commitb716e902ba53f4128c64e558c07524689a07a8c2 (patch)
treef084beb072f665d921fe76ab52c8215304cb2902 /Userland/Applications/Mail/CMakeLists.txt
parente80f8746b1e6772632f7655846bee9daa6a7b2ef (diff)
downloadserenity-b716e902ba53f4128c64e558c07524689a07a8c2.zip
Mail: Add an e-mail application called Mail
This utilises LibIMAP and LibWeb to provide an e-mail client. The only way currently to connect to a server and login is with a config file. This config file should be stored in ~/.config/Mail.ini Here is an example config file: ``` [Connection] Server=email.example.com Port=993 TLS=true [User] Username=test@example.com Password=Example!1 ``` Since this is stored in plaintext and uses a less secure login method, I'd recommend not using this on your main accounts :^) This has been tested on Gmail and Outlook. For Gmail, you either have to generate an app password if you have 2FA enabled, or enable access from less secure apps in your account settings.
Diffstat (limited to 'Userland/Applications/Mail/CMakeLists.txt')
-rw-r--r--Userland/Applications/Mail/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/Userland/Applications/Mail/CMakeLists.txt b/Userland/Applications/Mail/CMakeLists.txt
new file mode 100644
index 0000000000..6479aa3447
--- /dev/null
+++ b/Userland/Applications/Mail/CMakeLists.txt
@@ -0,0 +1,19 @@
+serenity_component(
+ Mail
+ RECOMMENDED
+ TARGETS Mail
+)
+
+compile_gml(MailWindow.gml MailWindowGML.h mail_window_gml)
+
+set(SOURCES
+ AccountHolder.cpp
+ InboxModel.cpp
+ MailboxTreeModel.cpp
+ MailWidget.cpp
+ MailWindowGML.h
+ main.cpp
+)
+
+serenity_app(Mail ICON app-mail)
+target_link_libraries(Mail LibCore LibDesktop LibGfx LibGUI LibIMAP LibWeb)