summaryrefslogtreecommitdiff
path: root/Userland/Applications/FontEditor/CMakeLists.txt
diff options
context:
space:
mode:
authorthankyouverycool <66646555+thankyouverycool@users.noreply.github.com>2022-03-17 08:56:02 -0400
committerAndreas Kling <kling@serenityos.org>2022-03-18 01:12:26 +0100
commita3956da6dc4998bcad1befd5b7893f6f6cdac430 (patch)
tree56761b1cf35fb0143075b8ae0cc22af0d935bb34 /Userland/Applications/FontEditor/CMakeLists.txt
parent5c27ce2561ad60af4a16a1f6b3dda9ea49b99250 (diff)
downloadserenity-a3956da6dc4998bcad1befd5b7893f6f6cdac430.zip
FontEditor: Make undo/redo compatible with multi-glyph selections
Previously the glyph undo stack saved an array of bytes representing the restore state of an individual glyph when modified. Now the selection undo stack saves a byte buffer of the entire selection, letting us restore changes to multiple glyphs at once.
Diffstat (limited to 'Userland/Applications/FontEditor/CMakeLists.txt')
-rw-r--r--Userland/Applications/FontEditor/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Userland/Applications/FontEditor/CMakeLists.txt b/Userland/Applications/FontEditor/CMakeLists.txt
index 31ee3f79c6..2e6339d61e 100644
--- a/Userland/Applications/FontEditor/CMakeLists.txt
+++ b/Userland/Applications/FontEditor/CMakeLists.txt
@@ -17,7 +17,7 @@ set(SOURCES
NewFontDialog.cpp
NewFontDialogPage1GML.h
NewFontDialogPage2GML.h
- UndoGlyph.h
+ UndoSelection.h
)
serenity_app(FontEditor ICON app-font-editor)