summaryrefslogtreecommitdiff
path: root/Userland/Applications/FontEditor/CMakeLists.txt
diff options
context:
space:
mode:
authorthankyouverycool <66646555+thankyouverycool@users.noreply.github.com>2021-04-10 13:47:23 -0400
committerAndreas Kling <kling@serenityos.org>2021-04-11 01:16:34 +0200
commit07627b374216404d5e31f1581eea4e8c8e0c4a90 (patch)
treee3e6badb48b43fdd2a3dd6b8d5cc7bbae92a580a /Userland/Applications/FontEditor/CMakeLists.txt
parentcdfa2614b958b4e70987cbb3e4c51136f60f70d9 (diff)
downloadserenity-07627b374216404d5e31f1581eea4e8c8e0c4a90.zip
FontEditor: Add 'New Font' wizard to editor
Take a comfy guided tour through new font creation.
Diffstat (limited to 'Userland/Applications/FontEditor/CMakeLists.txt')
-rw-r--r--Userland/Applications/FontEditor/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Userland/Applications/FontEditor/CMakeLists.txt b/Userland/Applications/FontEditor/CMakeLists.txt
index eb760d4401..80d30b66b6 100644
--- a/Userland/Applications/FontEditor/CMakeLists.txt
+++ b/Userland/Applications/FontEditor/CMakeLists.txt
@@ -1,5 +1,7 @@
include_directories(${CMAKE_CURRENT_BINARY_DIR})
compile_gml(FontEditorWindow.gml FontEditorWindowGML.h font_editor_window_gml)
+compile_gml(NewFontDialogPage1.gml NewFontDialogPage1GML.h new_font_dialog_page_1_gml)
+compile_gml(NewFontDialogPage2.gml NewFontDialogPage2GML.h new_font_dialog_page_2_gml)
set(SOURCES
FontEditor.cpp
@@ -7,6 +9,9 @@ set(SOURCES
GlyphEditorWidget.cpp
GlyphMapWidget.cpp
main.cpp
+ NewFontDialog.cpp
+ NewFontDialogPage1GML.h
+ NewFontDialogPage2GML.h
)
serenity_app(FontEditor ICON app-font-editor)