summaryrefslogtreecommitdiff
path: root/Userland/Applications/FontEditor/CMakeLists.txt
diff options
context:
space:
mode:
authorGunnar Beutner <gbeutner@serenityos.org>2021-06-15 15:16:32 +0200
committerAndreas Kling <kling@serenityos.org>2021-06-17 11:03:51 +0200
commit631d36fd9821e48b3b3b53ac609e2e50b254d15b (patch)
tree48f8af868a0ff3a66bb8d8435aca497bef093113 /Userland/Applications/FontEditor/CMakeLists.txt
parent6e094b8dbe91bea983284c747eaba5c6083eb364 (diff)
downloadserenity-631d36fd9821e48b3b3b53ac609e2e50b254d15b.zip
Everywhere: Add component declarations
This adds component declarations so that users can select to not build certain parts of the OS.
Diffstat (limited to 'Userland/Applications/FontEditor/CMakeLists.txt')
-rw-r--r--Userland/Applications/FontEditor/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Userland/Applications/FontEditor/CMakeLists.txt b/Userland/Applications/FontEditor/CMakeLists.txt
index 69f67b12ab..37422c4a81 100644
--- a/Userland/Applications/FontEditor/CMakeLists.txt
+++ b/Userland/Applications/FontEditor/CMakeLists.txt
@@ -1,3 +1,9 @@
+serenity_component(
+ FontEditor
+ RECOMMENDED
+ TARGETS FontEditor
+)
+
include_directories(${CMAKE_CURRENT_BINARY_DIR})
compile_gml(FontEditorWindow.gml FontEditorWindowGML.h font_editor_window_gml)
compile_gml(NewFontDialogPage1.gml NewFontDialogPage1GML.h new_font_dialog_page_1_gml)