summaryrefslogtreecommitdiff
path: root/Userland/Applications/FileManager/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-01-12 12:05:23 +0100
committerAndreas Kling <kling@serenityos.org>2021-01-12 12:05:23 +0100
commitdc28c07fa526841e05e16161c74a6c23984f1dd5 (patch)
treed68796bc7708eba33fbf7247e1a92188ac5acf6f /Userland/Applications/FileManager/CMakeLists.txt
parentaa939c4b4b8a7eb1d22b166ebb5fb737d6e66714 (diff)
downloadserenity-dc28c07fa526841e05e16161c74a6c23984f1dd5.zip
Applications: Move to Userland/Applications/
Diffstat (limited to 'Userland/Applications/FileManager/CMakeLists.txt')
-rw-r--r--Userland/Applications/FileManager/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Userland/Applications/FileManager/CMakeLists.txt b/Userland/Applications/FileManager/CMakeLists.txt
new file mode 100644
index 0000000000..d81fc89bef
--- /dev/null
+++ b/Userland/Applications/FileManager/CMakeLists.txt
@@ -0,0 +1,13 @@
+compile_gml(FileManagerWindow.gml FileManagerWindowGML.h file_manager_window_gml)
+
+set(SOURCES
+ DesktopWidget.cpp
+ DirectoryView.cpp
+ FileManagerWindowGML.h
+ FileUtils.cpp
+ main.cpp
+ PropertiesWindow.cpp
+)
+
+serenity_app(FileManager ICON filetype-folder)
+target_link_libraries(FileManager LibGUI LibDesktop)