summaryrefslogtreecommitdiff
path: root/Userland/Applications/Browser/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Flynn <trflynn89@pm.me>2021-03-25 07:34:55 -0400
committerAndreas Kling <kling@serenityos.org>2021-03-26 22:58:31 +0100
commitcd82fd24e21e96e528a05595db311764903462a8 (patch)
tree94a3cdc5bf75f00ee354464d1d4f99c180a9704c /Userland/Applications/Browser/CMakeLists.txt
parent990e362a17da87ad55bef826f026d1c3643f00f7 (diff)
downloadserenity-cd82fd24e21e96e528a05595db311764903462a8.zip
Browser: Add right-click context menu item for editing bookmarks
This allows users to right-click on a bookmark button to open a small dialog for editing bookmark titles and URLs.
Diffstat (limited to 'Userland/Applications/Browser/CMakeLists.txt')
-rw-r--r--Userland/Applications/Browser/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Userland/Applications/Browser/CMakeLists.txt b/Userland/Applications/Browser/CMakeLists.txt
index 4652ec8b11..7e7016a4cf 100644
--- a/Userland/Applications/Browser/CMakeLists.txt
+++ b/Userland/Applications/Browser/CMakeLists.txt
@@ -1,4 +1,5 @@
compile_gml(BrowserWindow.gml BrowserWindowGML.h browser_window_gml)
+compile_gml(EditBookmark.gml EditBookmarkGML.h edit_bookmark_gml)
compile_gml(Tab.gml TabGML.h tab_gml)
set(SOURCES
@@ -12,6 +13,7 @@ set(SOURCES
Tab.cpp
WindowActions.cpp
BrowserWindowGML.h
+ EditBookmarkGML.h
TabGML.h
)