summaryrefslogtreecommitdiff
path: root/Userland/Applications/About/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-01-12 12:05:23 +0100
committerAndreas Kling <kling@serenityos.org>2021-01-12 12:05:23 +0100
commitdc28c07fa526841e05e16161c74a6c23984f1dd5 (patch)
treed68796bc7708eba33fbf7247e1a92188ac5acf6f /Userland/Applications/About/CMakeLists.txt
parentaa939c4b4b8a7eb1d22b166ebb5fb737d6e66714 (diff)
downloadserenity-dc28c07fa526841e05e16161c74a6c23984f1dd5.zip
Applications: Move to Userland/Applications/
Diffstat (limited to 'Userland/Applications/About/CMakeLists.txt')
-rw-r--r--Userland/Applications/About/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Userland/Applications/About/CMakeLists.txt b/Userland/Applications/About/CMakeLists.txt
new file mode 100644
index 0000000000..0b3023c819
--- /dev/null
+++ b/Userland/Applications/About/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(SOURCES
+ main.cpp
+)
+
+execute_process(COMMAND "git rev-parse --short HEAD" OUTPUT_VARIABLE GIT_COMMIT)
+execute_process(COMMAND "git rev-parse --abbrev-ref HEAD" OUTPUT_VARIABLE GIT_BRANCH)
+execute_process(COMMAND "git diff-index --quiet HEAD -- && echo tracked || echo untracked" OUTPUT_VARIABLE GIT_CHANGES)
+
+add_definitions(-DGIT_COMMIT="${GIT_COMMIT}" -DGIT_BRANCH="${GIT_BRANCH}" -DGIT_CHANGES="${GIT_CHANGES}")
+
+serenity_bin(About)
+target_link_libraries(About LibGUI)