summaryrefslogtreecommitdiff
path: root/Tests/LibTextCodec/CMakeLists.txt
diff options
context:
space:
mode:
authorKarol Kosek <krkk@serenityos.org>2022-03-27 21:41:51 +0200
committerAndreas Kling <kling@serenityos.org>2022-03-29 01:01:32 +0200
commitdcb24e943ddb3f6a0f3320d598e6a48c2cb0efd4 (patch)
tree834b6bb890accd9bd8a01293704064f00cf28d4e /Tests/LibTextCodec/CMakeLists.txt
parentb006a60366c513528d0f7fe818be2558150e9b11 (diff)
downloadserenity-dcb24e943ddb3f6a0f3320d598e6a48c2cb0efd4.zip
Tests: Add a basic UTF-8 to UTF-8 LibTextCodec test
Diffstat (limited to 'Tests/LibTextCodec/CMakeLists.txt')
-rw-r--r--Tests/LibTextCodec/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/LibTextCodec/CMakeLists.txt b/Tests/LibTextCodec/CMakeLists.txt
new file mode 100644
index 0000000000..ec39ad694f
--- /dev/null
+++ b/Tests/LibTextCodec/CMakeLists.txt
@@ -0,0 +1,7 @@
+set(TEST_SOURCES
+ TestTextDecoders.cpp
+)
+
+foreach(source IN LISTS TEST_SOURCES)
+ serenity_test("${source}" LibTextCodec LIBS LibTextCodec)
+endforeach()