summaryrefslogtreecommitdiff
path: root/Tests/LibCpp/CMakeLists.txt
diff options
context:
space:
mode:
authorItamar <itamar8910@gmail.com>2021-05-17 11:06:30 +0300
committerAndreas Kling <kling@serenityos.org>2021-05-19 23:19:07 +0200
commit832e9c6e02b3629db8d5303fb94ec9d0e7a7b145 (patch)
treefeba63a26148ac8d52813e395dfa7b6ddba61392 /Tests/LibCpp/CMakeLists.txt
parentfbf796cd9f8934b3cdcdbb398dc78b61a6e830c1 (diff)
downloadserenity-832e9c6e02b3629db8d5303fb94ec9d0e7a7b145.zip
LibCpp: Add regression tests for the parser
For each .cpp file in the test suite data, there is a .ast file that represents the "known good" baseline of the parser result. Each .cpp file goes through the parser, and the result of invoking `ASTNode::dump()` on the root node is compared to the baseline to find regressions. We also check that there were no parser errors when parsing the .cpp files.
Diffstat (limited to 'Tests/LibCpp/CMakeLists.txt')
-rw-r--r--Tests/LibCpp/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/LibCpp/CMakeLists.txt b/Tests/LibCpp/CMakeLists.txt
new file mode 100644
index 0000000000..cbcd3b7488
--- /dev/null
+++ b/Tests/LibCpp/CMakeLists.txt
@@ -0,0 +1,5 @@
+file(GLOB CMD_SOURCES CONFIGURE_DEPENDS "*.cpp")
+
+foreach(CMD_SRC ${CMD_SOURCES})
+ serenity_test(${CMD_SRC} LibCpp LIBS LibCpp)
+endforeach()