summaryrefslogtreecommitdiff
path: root/Tests/LibCore/CMakeLists.txt
diff options
context:
space:
mode:
authorsin-ack <sin-ack@users.noreply.github.com>2021-05-10 09:27:04 +0000
committerAndreas Kling <kling@serenityos.org>2021-05-12 22:38:20 +0200
commit60eb4adac2e3ceef09baef5b441990f5390503ac (patch)
tree88a1dccc5b5257ba1b2c0be6636069a08b6c0e31 /Tests/LibCore/CMakeLists.txt
parentae9e35210404e901d2ec9c936ee00fa7dafcbadb (diff)
downloadserenity-60eb4adac2e3ceef09baef5b441990f5390503ac.zip
Tests: Add InodeWatcher and FileWatcher tests
This patch adds some rudimentary tests for InodeWatcher. It tests the basic functionality, but maybe there are corner cases I haven't caught. Additionally, this is our first LibCore test. :^)
Diffstat (limited to 'Tests/LibCore/CMakeLists.txt')
-rw-r--r--Tests/LibCore/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/LibCore/CMakeLists.txt b/Tests/LibCore/CMakeLists.txt
new file mode 100644
index 0000000000..1a949bfd2f
--- /dev/null
+++ b/Tests/LibCore/CMakeLists.txt
@@ -0,0 +1,8 @@
+set(
+ TEST_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/TestLibCoreFileWatcher.cpp
+)
+
+foreach(source ${TEST_SOURCES})
+ serenity_test(${source} LibCore)
+endforeach()