summaryrefslogtreecommitdiff
path: root/Tests/LibC/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2022-11-17 20:43:42 +0100
committerAndreas Kling <kling@serenityos.org>2022-11-19 11:11:13 +0100
commit524baa29e866d6ee5ef2340c911d626c0b247ce8 (patch)
tree08fddaf6a3350e40f3f489cbdcb60553b17be9e6 /Tests/LibC/CMakeLists.txt
parentcc189ce0f367023af6d27b9b7ed7499318961eab (diff)
downloadserenity-524baa29e866d6ee5ef2340c911d626c0b247ce8.zip
LibC+Tests: Simplify getpwuid_r() and getpwnam_r() and add tests
These functions are now implemented in terms of getpwent_r() which allows us to remove two FIXMEs about global variable shenanigans. I'm also adding tests for both APIs. :^)
Diffstat (limited to 'Tests/LibC/CMakeLists.txt')
-rw-r--r--Tests/LibC/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/LibC/CMakeLists.txt b/Tests/LibC/CMakeLists.txt
index cd9ac9ebfe..1825ed23e4 100644
--- a/Tests/LibC/CMakeLists.txt
+++ b/Tests/LibC/CMakeLists.txt
@@ -20,6 +20,7 @@ set(TEST_SOURCES
TestPThreadPriority.cpp
TestPthreadSpinLocks.cpp
TestPthreadRWLocks.cpp
+ TestPwd.cpp
TestQsort.cpp
TestRaise.cpp
TestRealpath.cpp