summaryrefslogtreecommitdiff
path: root/Tests/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2021-10-22 12:02:11 +0300
committerAndreas Kling <kling@serenityos.org>2021-10-22 13:13:00 +0200
commitcf0dbc9069645c966b9dcda3c00acdf506069dc3 (patch)
tree288a11780e8e146b86eefc76ebda2e30cf9da5da /Tests/Kernel/CMakeLists.txt
parent026687816d65a28bd3a553c7a343d8b3421a9483 (diff)
downloadserenity-cf0dbc9069645c966b9dcda3c00acdf506069dc3.zip
Tests: Add a unit test to ensure the /dev/mem device works correctly
To ensure everything works as expected, a unit test was added with multiple scenarios. This binary has to have the SetUID flag, and we also bind-mount the /usr/Tests directory to allow running of SetUID binaries.
Diffstat (limited to 'Tests/Kernel/CMakeLists.txt')
-rw-r--r--Tests/Kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/Kernel/CMakeLists.txt b/Tests/Kernel/CMakeLists.txt
index 746f195593..18abcba55a 100644
--- a/Tests/Kernel/CMakeLists.txt
+++ b/Tests/Kernel/CMakeLists.txt
@@ -37,6 +37,7 @@ set(LIBTEST_BASED_SOURCES
TestKernelFilePermissions.cpp
TestKernelPledge.cpp
TestKernelUnveil.cpp
+ TestMemoryDeviceMmap.cpp
TestMunMap.cpp
TestProcFS.cpp
)