summaryrefslogtreecommitdiff
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorHendiadyoin1 <leon2002.la@gmail.com>2021-11-29 18:18:34 +0100
committerAli Mohammad Pur <Ali.mpfard@gmail.com>2021-11-29 23:17:05 +0330
commit7a27ecc1352730b981ce9d6b2b6019c934377243 (patch)
tree25ac788a459c3b02472efef5e0c785921c95f81b /Tests/CMakeLists.txt
parent3a4dd5ff8744b0ed2c7d2939c984505051dfa11b (diff)
downloadserenity-7a27ecc1352730b981ce9d6b2b6019c934377243.zip
Tests: Add a simple LibGL render-test
At the moment we just check if we *can* render a simple triangle, we do not yet actually test if the image is indeed the triangle we wanted. This test also outputs the rendered image when GL_DEBUG is enabled to a file called "picture.bmp" for manual verification. Co-authored-by: sunverwerth <s.unverwerth@serenityos.org>
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index b2e5d2611a..0a2f7c9fd5 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -6,6 +6,7 @@ add_subdirectory(LibCore)
add_subdirectory(LibCpp)
add_subdirectory(LibELF)
add_subdirectory(LibGfx)
+add_subdirectory(LibGL)
add_subdirectory(LibIMAP)
add_subdirectory(LibJS)
add_subdirectory(LibM)