summaryrefslogtreecommitdiff
path: root/Tests/AK/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Flynn <trflynn89@pm.me>2021-08-28 11:19:21 -0400
committerLinus Groh <mail@linusgroh.de>2021-08-30 19:42:40 +0100
commit587d4663a339200a82b518d74c9400f4b77c8380 (patch)
tree89b573b4810cf478036247e46065b60f75e051c3 /Tests/AK/CMakeLists.txt
parentaa2e19e58f51ff2b6648809fc6a4d4ce1dc9df48 (diff)
downloadserenity-587d4663a339200a82b518d74c9400f4b77c8380.zip
AK: Return early from swap() when swapping the same object
When swapping the same object, we could end up with a double-free error. This was found while quick-sorting a Vector of Variants holding complex types, reproduced by the new swap_same_complex_object test case.
Diffstat (limited to 'Tests/AK/CMakeLists.txt')
-rw-r--r--Tests/AK/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/AK/CMakeLists.txt b/Tests/AK/CMakeLists.txt
index 61cb63a14e..ba5f1fb7c0 100644
--- a/Tests/AK/CMakeLists.txt
+++ b/Tests/AK/CMakeLists.txt
@@ -51,6 +51,7 @@ set(AK_TEST_SOURCES
TestSourceLocation.cpp
TestSpan.cpp
TestStack.cpp
+ TestStdLibExtras.cpp
TestString.cpp
TestStringUtils.cpp
TestStringView.cpp