summaryrefslogtreecommitdiff
path: root/Tests/AK/CMakeLists.txt
diff options
context:
space:
mode:
authorTom <tomut@yahoo.com>2022-02-18 20:11:02 -0700
committerLinus Groh <mail@linusgroh.de>2022-03-08 23:05:44 +0100
commit2f0e3da142730d422437b7d9e07f638f2da4ff9d (patch)
treeadc9bd7696fd6dd7781061cb66b966a6817fd2a6 /Tests/AK/CMakeLists.txt
parentf235f08e6d58396cb3886bf3449d1ff58e28f4c0 (diff)
downloadserenity-2f0e3da142730d422437b7d9e07f638f2da4ff9d.zip
AK: Add IPv6Address class
This is the IPv6 counter part to the IPv4Address class and implements parsing strings into a in6_addr and formatting one as a string. It supports the address compression scheme as well as IPv4 mapped addresses.
Diffstat (limited to 'Tests/AK/CMakeLists.txt')
-rw-r--r--Tests/AK/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/AK/CMakeLists.txt b/Tests/AK/CMakeLists.txt
index eed34f479a..7a62045a7e 100644
--- a/Tests/AK/CMakeLists.txt
+++ b/Tests/AK/CMakeLists.txt
@@ -32,6 +32,7 @@ set(AK_TEST_SOURCES
TestHashTable.cpp
TestHex.cpp
TestIPv4Address.cpp
+ TestIPv6Address.cpp
TestIndexSequence.cpp
TestIntegerMath.cpp
TestIntrusiveList.cpp