summaryrefslogtreecommitdiff
path: root/Tests/AK/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Klishch <danilklishch@gmail.com>2022-10-25 14:00:49 -0400
committerAndrew Kaster <andrewdkaster@gmail.com>2022-11-03 20:17:09 -0600
commitfdc53a5995f7e7dc554f5be9ffc1cd96009f889a (patch)
treedb2eee028ab1430ab0be9b049f00ebe07be3c2a0 /Tests/AK/CMakeLists.txt
parent17c9a3e8d951420bd85f7445c829bc6fbde4ade2 (diff)
downloadserenity-fdc53a5995f7e7dc554f5be9ffc1cd96009f889a.zip
AK: Add framework for a unified floating point to string conversion
Currently, the floating point to string conversion is implemented several times across the codebase. This commit provides a pretty low-level function to unify all of such conversions. It converts the given double to a fixed point decimal satisfying a few correctness criteria.
Diffstat (limited to 'Tests/AK/CMakeLists.txt')
-rw-r--r--Tests/AK/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/AK/CMakeLists.txt b/Tests/AK/CMakeLists.txt
index 469c2029b0..c52cf9925f 100644
--- a/Tests/AK/CMakeLists.txt
+++ b/Tests/AK/CMakeLists.txt
@@ -62,6 +62,7 @@ set(AK_TEST_SOURCES
TestStack.cpp
TestStdLibExtras.cpp
TestString.cpp
+ TestStringFloatingPointConversions.cpp
TestStringUtils.cpp
TestStringView.cpp
TestTime.cpp