summaryrefslogtreecommitdiff
path: root/Tests/AK/CMakeLists.txt
diff options
context:
space:
mode:
authorJelle Raaijmakers <jelle@gmta.nl>2023-02-17 17:06:03 +0100
committerAndreas Kling <kling@serenityos.org>2023-02-18 01:45:00 +0100
commitf4342c9118fb7a4be5d305dcad8b65939a6fca20 (patch)
tree335fc6663cf0f90964e429a24f4a2c75fcacabd0 /Tests/AK/CMakeLists.txt
parent3275d659bfc5a7c429b8b6a34023a47c9b8de551 (diff)
downloadserenity-f4342c9118fb7a4be5d305dcad8b65939a6fca20.zip
AK: Add `AK::SIMD::exp_approximate`
This approximation tries to generate values within 0.1% of their actual expected value. Microbenchmarks indicate that this iterative SIMD version can be up to 60x faster than `AK::SIMD::exp`.
Diffstat (limited to 'Tests/AK/CMakeLists.txt')
-rw-r--r--Tests/AK/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/AK/CMakeLists.txt b/Tests/AK/CMakeLists.txt
index 77a288d2ea..e26a38e41f 100644
--- a/Tests/AK/CMakeLists.txt
+++ b/Tests/AK/CMakeLists.txt
@@ -61,6 +61,7 @@ set(AK_TEST_SOURCES
TestQuickSort.cpp
TestRedBlackTree.cpp
TestRefPtr.cpp
+ TestSIMD.cpp
TestSinglyLinkedList.cpp
TestSourceGenerator.cpp
TestSourceLocation.cpp