summaryrefslogtreecommitdiff
path: root/Shell/CMakeLists.txt
diff options
context:
space:
mode:
authorAnotherTest <ali.mpfard@gmail.com>2020-06-17 18:05:06 +0430
committerAndreas Kling <kling@serenityos.org>2020-07-05 15:43:14 +0200
commita4627f24390035a8a8402e019be42b03f525f034 (patch)
tree5f4d8832790d8a899d43f08ba89a81fe7b3647c5 /Shell/CMakeLists.txt
parent6f7ac5d2e29d3dc764a565c2fb6425af8ee673d3 (diff)
downloadserenity-a4627f24390035a8a8402e019be42b03f525f034.zip
Shell: Switch to a new parser and AST
This commit also completely reworks the execution, highlighting and completion model to work with the new AST. New additions: - $(...) stdout captures - fd>&fd redirections - fd>&- redirections (close fd) - read-write redirections (<> path) - completely event-based execution - the weird idea of allowing the user to redirect the shell's own fds - variables in strings - local variables - minimal list support - adding hyperlinks to all paths that exist
Diffstat (limited to 'Shell/CMakeLists.txt')
-rw-r--r--Shell/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Shell/CMakeLists.txt b/Shell/CMakeLists.txt
index bf35dab3a9..339f9a48de 100644
--- a/Shell/CMakeLists.txt
+++ b/Shell/CMakeLists.txt
@@ -1,4 +1,6 @@
set(SOURCES
+ AST.cpp
+ Builtin.cpp
main.cpp
Parser.cpp
Shell.cpp